Azure AD 8x8 Application Logout Generates Microsoft Error Code AADSTS750054

Azure AD 8x8 Application Logout Generates Microsoft Error Code AADSTS750054

Symptom

When logging out of an 8x8 application, a Microsoft error message appears, displaying code AADSTS750054.

Applies To

  • 8x8 Applications
  • Microsoft Azure
  • Single Sign-On

Resolution

To resolve this issue:

  1. Navigate to 8x8 Admin Console.
  2. Click on Home > Identity and Security.

  1. Delete the currently-applied URL in Single Sign-On Integration (SSO) Sign-out page URL. This is typically the same URL as the Sign-in page URL.
  2. Click Save to complete the change.
  3. Test your logout functionality to confirm the fix.

Cause

This issue can occur with 8x8 applications when both of the following apply:

  • Single Sign-On of 8x8 applications has been configured in both 8x8 Admin Console > Identity and Security and Microsoft Azure.
  • The tenant-specific (Microsoft-suggested) Azure SSO Logout URL has been applied to the 8x8 SSO configuration in 8x8 Admin Console.

Additional Information