Overview
Familiarizing yourself with common network troubleshooting
tips can help resolve common error codes.
If any of these errors persist please reach out to your
administrator or our support team for more troubleshooting help.
Understanding SIP
SIP (Session Initiation Protocol) is a signaling protocol
widely used for setting up, connecting, and disconnecting communication
sessions, typically voice or video calls over the Internet.
SIP is an application-layer control protocol that supports
five parts making and stopping communications. The five parts of setting up and
terminating calls that SIP handles are:
User
Location - Determines where the end system is for a call.
User
Availability - Determination of the willingness (availability)
of the called party to engage in a call.
User
Capabilities - Determination of the media and parameters used
for the call.
Session
Setup - Establishment of the session parameters from both
parties (ringing).
Session
Management - Invoking the services, including transfer,
termination, and modifying the session parameters.
Error Types
When seeing a message saying “Unable to connect to
phone service” one of the following errors might be the main cause.
DNS Error
The VOClient stack was unable to resolve the IP address of
the SIP server.
Potential causes
Potential solutions
Potential causes
Local
connectivity issue
Remote
SIP server port blocked by firewall
TCP
protocol blocked by firewall
No
route to a SIP server (routing issue)
TCP
connection failure
TLS
handshake failure (certificate error)
Potential solutions
Check
local connectivity (WiFi or Ethernet)
Do
you connect to other non-8x8 related services?
Check
all firewall/router configurations
Check
8x8 SIP service ports are open
Ensure
SIP traffic is not proxied (man-in-middle)
Ensure
SIP ALG is disabled on the router
Failed Authentication
The SIP authentication failed.
Potential causes
Potential solutions
Check
the customer's account on the PBX.
Most
often, resetting the customer's account resolves this issue.
Time Out Error
While trying to connect to the SIP server, there was some
network-related error.
Potential causes
Potential solutions
Other Error
More investigation is necessary to identify the potential
causes.
Potential causes
Potential solutions
Known Limitations
As part of setting up telephony on a Windows system, 8x8
Work loads wlanapi.dll. Some antiviruses might flag this, as a
result we do recommend adding an exception for 8x8 Work.
If you are unable to make or receive communications after
reconfiguring your router, checking all cables, reconnecting phones, and
establishing ports for each device, contact your ISP provider.
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