Inspect Saved Configuration Error When Saving Line Key Configuration in 8x8 Admin Console

Inspect Saved Configuration Error When Saving Line Key Configuration in 8x8 Admin Console

Symptom

An error banner with the following message is displayed when attempting to save Line Key Configuration:

Error while saving line key configuration. Failed and creating power key. Please inspect the saved configuration.

 

Applies To

  • Admin Console
  • Desk Phone
  • Line Keys

Resolution

Remove the existing line keys and create new ones in their place:

  1. Access the 8x8 Admin Console.
  2. Click the Users icon.
  3. Locate the user profile experiencing the error.
  4. Click on the pencil icon on the right to Edit the user.
  5. Navigate to the Voice basic settings section.
  6. Click on the Line key Configuration link.
  7. Click on the More icon (three dots) for the top-most Line Appearance key. 
  8. Select Delete. This will delete the existing LAK.
  9. Click the + Line Appearance button.
  10. Select "Line appearance - User" from the dropdown list.
  11. Click Save in the Line appearance pop-up window. This will create a new LAK below any existing LAKs.
  12. Repeat steps 7-11 until all of the existing LAKs have been replaced.
  13. Click Save in the Edit device settings pop-up window.
  14. After replacing all of the existing LAKs, the line key configuration should successfully save.

Cause

The SubscriptionID associated with the existing Line Appearance Keys is missing. Re-creating them generates the correct SubscriptionID.

    • Related Articles

    • Failed Saving User Settings Error When Assigning a License in 8x8 Admin Console

      Symptom When attempting to assign a license to a new or existing user in Admin Console, you encounter the error Failed saving user settings. Applies To Admin Console Suspended Licenses Licenses Assigned to Deactivated Users Resolution Trying to ...
    • Error Saving Contact When Adding Contacts in 8x8 Admin Console

      Symptom When attempting to add Contacts there is an error that reads, "Error saving contact." In the browser console Network logs there is an error: {"httpStatus":"FAILED_DEPENDENCY","validationErrors":null,"message":"Could not create contact. ...
    • Adding Line Appearance Keys in 8x8 Admin Console

      Objective Add Line Appearance Keys (LAK) in 8x8 Admin Console. Known Limitation: Line Appearance Keys cannot be added to VVX 150, VVX 201/101, as they have only two keys on the phone which are occupied for both lines. Cisco phones show one key on the ...
    • Failed Saving User Settings Error When Assigning a Contact Center License

      Symptom When attempting to assign a 8x8 Contact Center (X6, X7, X8) license to a user in Admin Console, you encounter the error Failed saving user settings. Applies To Admin Console 8x8 Contact Center X Series X6, X7, X8 licenses Resolution This ...
    • Configure Power Keys in Admin Console

      Objective Configure Power Keys in Admin Console. Applies To Admin Console Power Keys Procedure 8x8 offers call handling and monitoring features used in conjunction with Poly phones with four lines or more. Power Keys allows you to handle multiple ...