Symptom
When attempting to assign a 8x8 Contact Center (X6,
X7, X8) license to a user in Admin Console, you encounter the error Failed
saving user settings.
Applies To
Resolution
This issue is potentially caused by one of the following
known root conditions:
Special characters
Make sure there are no special characters in First name,
Last name, Username.
Confirm and Correct Extension Conflict
In
the Virtual Contact Center (VCC) agent settings on the
user's edit page in Admin Console, identify the
suggested Extension number. Make note of this number.
Log
in to Admin Console.
In
Admin Console, under Users, search for a user with the
filter PBX# and the Extension number noted
in Step 1.
If a
user is returned in the results, create a case with 8x8 Support to correct
this. In the meantime, continue below to add the 8x8 Contact Center
license to the user.
Return
to Admin Console and the user's Virtual Contact Center (VCC) agent
settings.
Manually
enter a different Extension number that is not
already in use.
Scroll
down and Save your changes.
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Still seeing the error? Continue below.
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Confirm License Availability
Following a recent upgrade request or service cancellation,
it is possible you may have suspended licenses on the account that are
erroneously shown as available in the user license dropdown. Alternatively, you
may have technically available licenses currently assigned to deactivated
users. To review and correct for this possibility, see
Failed
Saving User Settings Error When Assigning a License in 8x8 Admin Console.
Cause
Extension Conflict
Admin Console is suggesting a user extension that is already
in use by another 8x8 Contact Center user, which is blocking the settings from
being saved. This can happen if:
A
8x8 Contact Center user has not successfully been removed from
the 8x8 Contact Center when the license was removed from them in
Admin Console or
A
8x8 Contact Center extension number change has not successfully completed.
License Availability
Suspended licenses that are stuck on the account after a
cancellation or upgrade request are causing that license type to appear in the
dropdown menu. Suspended licenses are not allowed to be assigned to users.
Alternatively, technically available licenses may currently
be assigned to deactivated users.