8x8 Analytics for Work API Error: Cannot Access Analytics Data 400 Bad Request Insufficient Permissions
Symptom
When attempting to retrieve call data records (CDR) via the
API, a 400 Bad Request error is received with the following message:
"user({userName}) does not have access to api category(CDR) for
pbxId([{pbxName}])." The error code associated with this issue is
105-400-038.
Applies To
Resolution
To resolve this issue, the following steps need to be taken:
Licence
Verification: Ensure that the user account being used to
authenticate the API request has been assigned a licence that
includes access to the 8x8 Analytics features.
Access
Level Verification: Confirm that the user account being used to
authenticate the API request has been granted Analytics:
Supervisor access to 8x8 Analytics for Work; this can be found
in Admin Console, Users, Edit, Analytics for 8x8 Work, Allowed access
level.
Once both the correct license and access level have been
provisioned for the user account, the API requests for call data records should
be successful.
Cause
This error indicates that the account used to authenticate
the API request does not have the necessary permissions to access the CDR data
for the PBX.
The user requires an appropriate license that includes
access to 8x8 Analytics features and supervisor-level access within the 8x8
Analytics for Work.
Additional Information
It is recommended that the user's access within the 8x8
Analytics for Work User Interface be verified to confirm that the user's
requirement for a license with analytics access and supervisor privileges
aligns with the necessary permissions to interact with the CDR data through the
API.
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